NCTAudioStudio2

NCTAudioStudio2 ActiveX DLLs
Version 2.2

Version 2.2

NCTAudioStudio2 is a package of 17 ActiveX Controls DLLs for work with audio data.

NCTAudioStudio2 includes the following ActiveX DLLs:

  • NCTAudioPlayer2 for playing audio data;

  • NCTAudioRecord2 for recording audio data;

  • NCTAudioFile2 for reading and writing audio data from and to audio files;

  • NCTWMAFile2 for reading and writing audio data from and to WMA audio files;

  • NCTAudioGrabber2 for grabbing CD audio;

  • NCTAudioTransform2 for processing and transforming audio data;

  • NCTAudioInformation2 for editing tags in audio files;

  • NCTTextToAudio2 for conversion text to voice;

  • NCTAudioDesign2 for designing audio application;

  • NCTAudioLibrary2 for organization of audio files at your local disks;

  • NCTAudioDisplay2 for visual representation of the left and right channels of audio data in process of playback or record;

  • NCTAudioVisualization2 for visual representation of audio data in process of playback or record;

  • NCTAudioVisualizationEx2 for visual representation of audio data in process of playback or record;

  • NCTAudioCompress2 for compressing and decompressing audio data in memory;

  • NCTDTMFRecognizer2 - for DTMF (Dual Tone Multi Frequency) recognizing;

  • NCTDXTransform2 - for applying preinstalled DirectX filters to the audio file or audio data array.

  • NCTWavChunksEditor2 - for editing information "chunks" in an audio file with The Radio Industry's Traffic Data WAVE File Standard specification.

With NCTAudioStudio2 you can:

  • Read and write audio data to and from audio files, including compressed (NCTAudioFile2, NCTWMAFile2);

  • Perform different operations with audio files (conversion, merging and so on) (NCTAudioFile2);

  • Edit info tags in audio file (NCTAudioInformation2);

  • Record (NCTAudioRecord2) and playback (NCTAudioPlayer2) audio data in real-time mode;

  • Control Mixer Devices in playback (NCTAudioPlayer2) and record processes (NCTAudioRecord2) in real-time mode.

  • Grab audio from audio CD (NCTAudioGrabber2);

  • Transform audio data (NCTAudioTransform2);

  • Design audio application (NCTAudioDesign2);

  • Create data base for your audio files (NCTAudioLibrary2);

  • Convert text from text file or string to voice (wav file or audio data) (NCTTextToAudio2);

  • Display audio signal or its spectrum in process of playback or record (NCTAudioVisualization2, NCTAudioDisplay2);

  • Compress and decompress audio data (NCTAudioFile2, NCTAudioCompress2);

The following audio formats are supported:

  • Uncompressed WAV PCM;

  • Compressed WAV (GSM, ADPCM, DSP and others);

  • MP2 (MPEG 1/2 Layer-2);

  • MP3 (MPEG 1/2 Layer-3);

  • VOX (Dialogic ADPCM);

  • RAW audio (PCM, A-LAW, U-LAW);

  • WMA (Windows Media Audio);

  • MPC (MusicPack);

  • AVI (audio track);

  • G.726, G.723, G.721;

  • Ogg Vorbis (Version 1.0);

  • AIFF (Apple audio format);

  • AU (UNIX audio format).

You can insert the NCTAudioStudio2 ActiveX Controls in your program, written in a language, which supports ActiveX automation.

    NCTAudioStudio2 was tested with:

  • MS Visual Basic .NET;

  • MS Visual Basic 6.0 (SP5);

  • MS Visual C++ 6.0 (SP5);

  • Borland C++ Builder 6.0;

  • C Sharp .NET;

  • Borland Delphi 6.0.

Lots of free MS Visual Basic 6.0, VB .NET, Visual C++ 6.0, Borland C++ Builder 6.0, Delphi 6.0, C Sharp .NET samples, that show how to use NCTAudioStudio2's controls, are included into the installation.

SYSTEM REQUIREMENTS:

  • Windows 98/Me/2000/XP,

  • Sound card,

  • Microphone (optional),

  • MS VB 6.0 or MS VC++ 6.0(SP5),

  • Microsoft Speech SDK 5.1 (for NCTTextToAudio2),

  • Windows Media Format Redistribute Package (for NCTWMAFile2),

  • CD drive (NCTAudioGrabber2).

You can send any questions to support@nctsoft.com

For more information see: http://www.nctsoft.com/products/NCTAudioStudio2

Send Feedback on the NCTAudioStudio2 documentation.
NCTAudioStudio2 was developed by NCT Company Ltd. http://www.nctsoft.com


AudioStudio2 using field

Using field

The NCTAudioStudio2 package of DLLs is an extensive and multi-purpose tool for work with audio data. The following list represents the same types of possible fields where the NCTAudioStudio2: Audio player, Audio recorder, Audio grabber, Inquiry system, Internet telephony can be used.

The use of NCTAudioStudio2 in this program products significantly decreases development time.


Audio grabber

Audio grabber

Example of the program which works with audio CDs. Grabs and compresses getting files CD for saving it on a computer. It allows to create a collection of music on a computer. Audio files can be transformed by NCTAudioTransform (applying filters, effects etc.) after grabbing.

The use of NCTAudioStudio2 in this program products significantly decreases development time.


Audio player

Audio player

Example of an audio player. It can be any audio player for playing music from audio files. Audio files can be transformed by NCTAudioTransform (applying filters, effects etc.) before playing.

The use of NCTAudioStudio2 in this program products significantly decreases development time.


Audio recorder

Audio recorder

Example of an audio recorder. It allows to create a collection of audio files on a computer. Audio files can be transformed by NCTAudioTransform (applying filters, effects etc.) after recording.

The use of NCTAudioStudio2 in this program products significantly decreases development time.


Inquiry system

Inquiry system

Example of an inquiry system. Person can get an answer by telephone from remote data base.

This example includes two NCT Company Ltd. program products. They are NCTTextToAudio ActiveX dll from NCTAudioStudio2 and NCTDialogicVoice. For more information about this products do to our site http://www.nctsoft.com/products/NCTDialogicVoice2/.

The use of NCTAudioStudio2 in this program products significantly decreases development time.


Internet telephony

Internet telephony

Internet Telephony technology lets you make voice phone calls over the Internet or other packet networks using your PC, via telephones. Conceptually, Internet telephone technology provides the following services: connects to a telephone, connects to any computer in the world that is connected to the Internet, takes the standard telephone signal, reverses the operation for packets coming in from the network and going out to the phone.

Example of the Internet telephony technology.

This is a symmetrical system where two telephones are situated on the both sides and the connection between them is released by the Internet. Data coming from one telephone via microphone is recorded, compressed and send to the other computer through the Internet. On this computer the data is decompressed and played by the loudspeaker of the second telephone.

The use of NCTAudioStudio2 in this program products significantly decreases development time.


What's new in AudioStudio2

What's new

The general features of NCTAudioStudio2 news are:

  • New dll for more possibilities of audio data visualization ( NCTAudioVisualizationEx2 )

  • New dll for applying preinstalled DirectX filters to the audio file or audio data array ( NCTDXTransform2 ). You can use all DirectX filters for sound changing.

  • New dll for editing information "chunks" in an audio file with The Radio Industry's Traffic Data WAVE File Standard specification (NCTWavChunksEditor2). This standard allows users to embed the common labeling information that radio users need.

  • New methods for audio data transformation ( NCTAudioTransform2 ).

  • New lots of free samples that show how to use NCTAudioStudio2's controls.

  • The NCTAudioBurner ActiveX dll is deleted from the NCTAudioStudio2 package but you can find analogue of this dll in the NCTDiscWriter package.

  • The ALF2CD format is not supported in the new version.

  • At present you can use two ways for an errors catch: using the standard error processor from VB or using the LastErrorNum property.


Start

Audio file types

The NCTAudioStudio2 supports the following audio codecs:

Codec | Description
ADPCM | Compressed WAV format. ADPCM (Adaptive Differential Pulse Code Modulation) is an audio compression scheme which compresses from 16-bit to 4-bit for a 4:1 compression ratio.
ALAW | Compressed WAV format. A-Law (or CCITT standard G.711) is an audio compression scheme common in telephony applications. It is a slight variation of the u-Law compression format, and is found in European systems. This encoding format compresses original 16-bit audio down to 8 bits (for a 2:1 compression ratio) with a dynamic range of about 13-bits. Thus, a-law encoded waveforms have a higher s/n ratio than 8-bit PCM, but at the price of a bit more distortion than the original 16-bit audio. The quality is higher than you would get with 4-bit ADPCM formats. Encoding and decoding is rather fast and generally, widely supported.
DSP | Compressed WAV format. DSP Group True Speech (TM) format.
GSM | Compressed WAV format. Good for keeping of human speech.
G.721 | Used for computer telephony. Good for keeping of human speech.
G.723 | Used for computer telephony. Good for keeping of human speech.
G.726 | Used for computer telephony. Good for keeping of human speech.
MP2 | MPEG Layer-2 format.
MP3 | MPEG Layer-3 format. Very popular format for keeping of music.
PCM | Standard Windows WAV format for non-compressed audio files. Pulse Code Modulation (PCM) is the standard method of digitally encoding audio. It is the basic uncompressed data format used in file types such as Windows .wav.
ULAW | Compressed WAV format. u-Law (or CCITT standard G.711) is an audio compression scheme and international standard in telephony applications. u-Law is very similar to A-Law, a variation of u-Law found in European systems. This encoding format compresses original 16-bit audio down to 8 bits (for a 2:1 compression ratio) with a dynamic range of about 13-bits. Thus, u-Law encoded waveforms have a higher s/n ratio than 8-bit PCM, but at the price of a bit more distortion than the original 16-bit audio. The quality is higher than you would get with 4-bit ADPCM formats. Encoding and decoding is rather fast and generally, widely supported.
VOX | Dialogic ADPCM format. The Dialogic ADPCM format is commonly found in telephony applications, and has been optimized for low sample rate voice. It will only save mono 16-bit audio, and like other ADPCM formats, it compresses to 4-bits/sample (for a 4:1 ratio). This format has no header, so any file format with the extension .VOX will be assumed to be in this format.
RAW | Raw format of audio files. Doesn't contain header of an audio file.
WMA | Windows Media Audio format. A special type of advanced streaming format file for use with audio content encoded with the Windows Media Audio codec. The .wma extension indicates a file format and how the content is encoded.
CCIT U-Law | Compressed WAV format.
Ogg Vorbis | Ogg Vorbis format.


NCTAudioStudio2 FAQ

NCTAudioStudio2 FAQ

FAQ: Frequently Asked Questions

  1. When I try to install my application that uses your ActiveX, it doesn't work. Do I have to install something special on the computers where I want to use my software based on your ActiveX controls?

  2. Can I re-distribute your ActiveX controls in my application without royalties ?

  3. If I only use NCTAudioFile2.dll (not use NCTWMAFile2.dll) in my program, can it support wma format?

  4. If NCTWMAFile must be used for supporting wma file, how do I register the dll correctly in a client computer? I always get an error message when I want to install NCTWMAFile2.dll on a client computer.

  5. If I do not like my users install another program (WMFADist.exe) before install my program, how should I do?

  6. I've installed NCTAudioStudio on my Win2000 computer and am trying to run the test WMA vb project. I am getting an error saying the NCTWMAFile2.dll could not be loaded. The project seems to require the WMA control but I had an error during the install saying the WMVCore.dll file could not be found. Any ideas?

  7. I noticed your NCTAudioStudio does not support NT. We require NT support can you provide a solution for WAV play and record.

  8. The WMA profiles do not all match what they are supposed to be. Also, you include video profiles in this version, which are not applicable. Even if you cycle through the profiles, and it shows what they are, when you save, that's not what it is. This is just one example: look at profile 20. It says 56kbps. However, the output file is 32kbps.

  9. What audio codecs are used in NCTAudioStudio2 for MP3 support?

  10. What is VBR?

  11. What is the difference between professional and advanced Fraunhofer codec?

  12. How can I know if Fraunhofer codec is installed in my system?

  13. How to install Lame codec?

  14. How to install the advanced Fraunhofer codec?

  15. I try to convert .VOX files to another format, but it failed. What is the matter?

  16. If the audio file without the header, how do I tell the control what format my input file is?

  17. For some reason the VOX (6khz) is not playing on some sound cards. If we change it to sample at 8Khz, it plays (fast of course.) Any suggestions?

  18. What I need to do to start recording when the sound card starts receiving a signal and stop recording when there is no signal for more than x number of seconds?

  19. How can I apply any audio effects to a stereo file?

  20. Do you have Active X controls for continuous fast forward and continuous rewind from a stop point in audio? Do you have a control for insert or overwrite of audio?

  21. Is it possible to merge audio files (MP3 and WAV) using AudioFile?

  22. Is it possible to use the AudioGrabber control to grab the tracks directly to WMA?

  23. How can I record in WMA format?

  24. How can I play two files in the same time?

  25. How can I convert a file from one format to another and amplify the converted file?

  26. How can I append sound to an existing file?

  27. I can playback audio file with NCTAudioPlayer2, but I can't change volume or volume balance.

  28. Is there a method for array data access? I'd like to create a simple graphic of audio spectrum.

  29. How to add NCT's components into my VC++ 6.0 project?

  30. I need to have AudioGrabber2 control on two different forms. The problem I run into is the control on the second screen won't read the number of tracks on the CD. It appears that two controls in the same program won't work. If I eliminate one then the other will work. I have to have both controls in order for my program to work properly. Do you have any suggestions or is this a problem with the control?

  1. When I try to install my application that uses your ActiveX, it doesn't work. Do I have to install something special on the computers where I want to use my software based on your ActiveX controls?

    Controls from NCTAudioStudio (NCTAudioEditor, NCTAudioConvert) are required some dependency files, which aren't included in our installation. Some of these files are listed in .dep files for each control. When you distribute your program, you should include these files in your installation. Controls may not be registered without these files. You can find .dep files for each control from NCTAudioStudio2 (NCTAudioConvert) in folder, where you installed it. Please check if you included all dependency files in your installation.

    Some installers take dependency files from .dep files automatically and include them in your installation. Then you should put .dep files in the folder where DLLs are located. You don't need to include .dep files in your installation.

    There is a very useful utility in MS Visual Studio: Dependency Walker. It recursively scans all the dependent modules required by a particular application. If you have any problems with controls registration, just open dlls that cannot be registered on a new computer in the utility and check if all the necessary files (and correct versions) to register this dll are on the computer or not.

    Firstly you should check the next files: OLEAUT32.DLL, ATL.DLL and MSVCRT.DLL. If they are absent you should include these files in the installation pakcage of your software and place them to the system folder during installation. Usually it is C:\winnt\System32 (NT/2000) or C:\Windows\System (Win98/ME/XP).

    OLEAUT32.DLL and MSVCRT.DLL are the same for all Windows. ATL.DLL is different for 95/98/Me and NT/2000/XP.

    NCTAudioStudio v.2.2 was compiled using MS C++ 7.0 (.NET). So it requires the MSVCR70.DLL file too.

    Also you have to place the lame_enc.dll file (from C:\Program Files\NCT\AudioConvert2\Redist) in the same directory as NCTAudioFile2.dll on a new computer. The file is necessary for MP3 support. Though lame_enc.dll has the .dll extansion, it does not have to be registered using the regsvr32 utility.

    You can register ActiveX DLLs and ActiveX EXE Servers manually.

    To register an ActiveX DLL you have to use the regsvr32 utility. For example to register NCTAudioFile2.dll you have to click Start>Run... and insert the following string in the text field of the Run window:
    regsvr32 C:\Program Files\NCT\AudioConvert2\Redist\NCTAudioFile.dll.

    To unregister an ActiveX DLL you should use regsvr32.exe with the /u key. For example:
    regsvr32 C:\Program Files\NCT\AudioConvert2\Redist\NCTAudioFile.dll /u.

    To register an ActiveX EXE server you should run the file and it registers itself, or you should run it with the key /regserver. For example to register NCTAudioConvert ActiveX EXE Server in your system click Start>Run... and insert the following string in the text field of the Run window:
    C:\Program Files\NCT\AudioConvert2\Redist\NCTAudioConvert.exe /regserver.
    You should use the /UnRegServer key to cancel registration. It does not show any messages when registration or unregistration is done.

    The easiest way to check if a control is registered in the system or not, is just to run a sample based on the control. If it does not registered, it shows an error message.

    We'd like to advice VB developers to read this Microsoft article: http://support.microsoft.com/support/kb/articles/Q290/8/87.ASP (FILE: VBRun60sp5.exe Installs Visual Basic 6.0 SP5 Run-Time Files Q290887).

    Recommend closing all programs during your software installation.

  2. Can I re-distribute your ActiveX controls in my application without royalties ?

    Yes, all our controls are royalty free. You pay only for registration one time. It does not apply to MP3 codecs. They are not royalty free. Visit MP3 codecs manufactures' web sites for more information.

  3. If I only use NCTAudioFile2.dll (not use NCTWMAFile2.dll) in my program, can it support wma format?

    No NCTAudioFile do not support WMA itself. It always links to NCTWMAFile.

  4. If NCTWMAFile must be used for supporting wma file, how do I register the dll correctly in a client computer? I always get an error message when I want to install NCTWMAFile2.dll on a client computer.

    You have to include the wmfdist.exe file into your installations. You can get the file in C:\Program Files\NCT\AudioStudio2\Redist folder after installation of NCTAudioStudio v.2.2. The wmfdist.exe file contains Windows Media Format 9 Series Runtime files by Microsoft.

  5. If I do not like my users install another program (WMFADist.exe) before install my program, how should I do?

    You can include the file into your installation and run it with the following paremeters: /Q:A /R:N. In this case it doesn't show any messages.

  6. I've installed NCTAudioStudio on my Win2000 computer and am trying to run the test WMA vb project. I am getting an error saying the NCTWMAFile2.dll could not be loaded. The project seems to require the WMA control but I had an error during the install saying the WMVCore.dll file could not be found. Any ideas?

    Turn off all applications and services that process WMA (for example: Windows Media Server). After that reinstall NCTAudioStudio. Or run the wmfdist.exe file in C:\Program Files\NCT\AudioStudio2\Redist folder. And when Windows Media Format 9 Series Runtime files are installed on your computer, register NCTWMAFile2.dll using the regsvr32 utility manualy.

  7. I noticed your NCTAudioStudio does not support NT. We require NT support can you provide a solution for WAV play and record.

    We must admit that we did not test NCTAudioStudio under WinNT. But some of our clients do use NCTAudioStudio's components under NT.

    Here are some problems that can appear with WinNT
    1. NCTWMAFile2.dll will not work under NT, because the control is based on WMA v.9 and it doesn't support Win98 and NT.
    2. There can be some problems with NCTAudioPlayer and NCTAudioRecord. But usually the problems disappear after installing the latest drivers for sound cards in this WinNT computer. Look for the drivers on the manufacturers' site of the sound card. If it does not help, we will have to create a special version of our controls for this particular sound card. We will do it only as a custom development for an additional fee.

  8. The WMA profiles do not all match what they are supposed to be. Also, you include video profiles in this version, which are not applicable. Even if you cycle through the profiles, and it shows what they are, when you save, that's not what it is. This is just one example: look at profile 20. It says 56kbps. However, the output file is 32kbps.

    Let's look at the complete description of profile 20 (see NCTAudioStudio's help: NCTAudioFile2 ActiveX DLL > the SetFormatWMA method or NCTWMAFile2 ActiveX DLL > the ProfileNum property):
    Profile no.: 20 - WMA 32,000 Hz; 16 Bit; Stereo; 32 kbps; - Audio for dial-up modems (56 Kbps stereo)

    It means that the file is created at 32 kbps bit rate and it is intended to be transferred using dial-up modems with the speed of 56 Kbps. The firs part (WMA 32,000 Hz; 16 Bit; Stereo; 32 kbps) shows the parameters of an audio file (use the WMAFile.FormatString property to get this information).
    The second (Audio for dial-up modems (56 Kbps stereo) shows the speed of stream data transmission this profile is recommended for (use the WMAFile.ProfileName property to get this information).

    Also please pay attention on the LoadProfileFile method in NCTWMAFile2. It loads a profile file (profile data is stored on disk in the form of an XML file with the .prx file name extension).

    A profile is a collection of data that describes the configuration of a WMA file. At a minimum, a profile must contain configuration settings for a single stream. The stream information in a profile contains the bit rate, buffer window, and media properties for the stream. The stream information for audio and video describes exactly how the media is configured in the file, including which codec (if any) will be used to compress the data.

    By default it is the system profile (WMSysPr9.prx from the system folder). It comes with the Windows Media Format 9 Runtime files installation. And we do not change it in any way.

    You can write very simple program based on NCTWMAFile to get profiles' information from .prx files.

    Private Sub Command1_Click()
    sProfileFile = C:\WINDOWS\WMSysPr9.prx
    'sProfileFile = C:\WINDOWS\WMSysPrx.prx
    'sProfileFile = C:\WINDOWS\WMSysPr8.prx

    WMAFile.LoadProfileFile sProfileFile
    Debug.Print File: & sProfileFile & - & WMAFile.ProfileCount

    For i = 1 To WMAFile.ProfileCount
    WMAFile.ProfileNum = i
    Debug.Print Profile no.: & WMAFile.ProfileNum & - & WMAFile.FormatString & - & WMAFile.ProfileName
    Next i
    End Sub

    Also you can create, edit and use your own .prx files using any text editor Or Profile Editor, a utility that is included with Windows Media Encoder 9 Series.

  9. What audio codecs are used in NCTAudioStudio2 for MP3 support?

    For MP3 files decoding you can choose between: Fraunhofer IIS MPEG Layer-3 Codec (advanced), Xaudio and MAD.

    For MP3 files encoding you can choose between: LAME Codec and Fraunhofer IIS MPEG Layer-3 Codec.

  10. What is VBR?

    VBR means Variable Bitrate. Some MP3 files can have variable bitrate, i.e. bitrate of file can be changed during record and playback. Lame codec V 3.91 supports VBR.

  11. What is the difference between professional and advanced Fraunhofer codec?

    Advanced version of the codec supports only low bitrates for encoding (to 56 kbps), but it supports higher bitrates for decoding. The professional version of the codec supports bitrates up to 128 kbps for encoding. You can get the advanced version of the codec with MS Windows Media Player.

  12. How can I know if Fraunhofer codec is installed in my system?

    You can check presence of Fraunhofer codec at Start -> Settings -> Control Panel -> Sounds and Multimedia -> Devices -> Audio Compression Codecs.

  13. How to install Lame codec?

    You have to place the lame_enc.dll file (from C:\Program Files\NCT\AudioConvert2\Redist) in the same directory as NCTAudioFile2.dll on a new computer. The file is necessary for MP3 support. Though lame_enc.dll has the .dll extansion, it does not have to be registered using the regsvr32 utility.

  14. How to install the advanced Fraunhofer codec?

    In Windows 95/98/XP: 1. Copy L3codeca.acm in System Directory (C:\Windows\System). 2. Add string in System.ini - Section drivers32: msacm.l3acm=l3codeca.acm.

    In Windows NT/2000: 1. Copy L3codeca.acm in System Directory (C:\WinNT\System32). 2. Add the key with the name msacm.l3acm and value l3codeca.acm to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Drivers32

  15. I try to convert .VOX files to another format, but it failed. What is the matter?

    There are many different audio formats that have the VOX extension. NCTAudioStudio2 defines .VOX files as Dialogic ADPCM audio files. This format has no header, so any formats with the VOX extension are usually taken for this format.

    Change the VOX extension to RAW or G726 (see SetFormatxxx methods in NCTAudioStudio2's help for more information). If it does not help, send us such a file to support@nctsoft.com, we will analyze it and inform you how to open it correctly.

    In future you should not change the extension of your files. You can set FormatType parameter of OpenFile method. For example: if you have a RAW file with .VOX extension, you can set FormatType to RAW thus you should not rename the file.

  16. If the audio file without the header, how do I tell the control what format my input file is?

    You should use SetFormatxxx methods for files without the header. The SetFormatxxx methods specify not only the OUTPUT files format, but the INTPUT files format too.

    You should always use the SetFormatXXX methods to operate with RAW (ULAW and ALAW), G.726 and VOX files, because these files without any header. Thus it is impossible to define their parameters (frequency, number of channels, bitrate). You should know them or you should pick the parameters experimentally.

    You should not use the SetFormatXXX methods to open another files format supported by NCTAudioStudio2.

  17. For some reason the VOX (6khz) is not playing on some sound cards. If we change it to sample at 8Khz, it plays (fast of course.) Any suggestions?

    It is a limitation of your sound card. Some sound cards do not support this frequency Try the follow VB code to pass over the limitation and open it correctly.

    AudioFile1.SetFormatVOX FQ_6_KHZ 'Sets the format of an audio file AudioFile1.OpenFile FileName 'Opens an audio file for reading AudioFile1.SetFormatArray FQ_8_KHZ, MONO 'Changes the frequency of internal array

  18. What I need to do to start recording when the sound card starts receiving a signal and stop recording when there is no signal for more than x number of seconds?

    You should use the AccuEnabled property (AudioRecord2) For more information see our help for NCTAudioStudio2: NCTAudioRecord2.

  19. How can I apply any audio effects to a stereo file?

    You should use NCTAudioTransform2 for this purpose. All effects are applied to a mono signal. So before applying any effects to stereo file you should separate left and right channels. Then you can apply an effect and after that you should mix channels. For more information see our help for NCTAudioStudio2: NCTAudioTransform2.

  20. Do you have Active X controls for continuous fast forward and continuous rewind from a stop point in audio? Do you have a control for insert or overwrite of audio?

    It is possible to implement it using existing controls from NCTAudioStudio2. You should use NCTAudioFile and NCTAudioPlayer. Please follow the link: http://www.nctsoft.com/products/NCTAudioStudio2/samples.aspx to get a sample.

  21. Is it possible to merge audio files (MP3 and WAV) using AudioFile?

    Yes, it possible. You should use NCTAudioTransform and NCTAudioFile. Please follow the link: http://www.nctsoft.com/products/NCTAudioStudio2/samples.aspx to get a sample.

  22. Is it possible to use the AudioGrabber control to grab the tracks directly to WMA?

    Yes, for that you should use NCTAudioGrabber2 and NCTWMAFile2 jointly. Please follow the link: http://www.nctsoft.com/products/NCTAudioStudio2/samples.aspx to get a sample.

  23. How can I record in WMA format?

    You can record in WMA format using NCTWMAFile2 and NCTAudioRecord2 controls. Please follow the link: http://www.nctsoft.com/products/NCTAudioStudio2/samples.aspx to get a sample.

  24. How can I play two files in the same time?

    There are two methods to make this:
    1) using two NCTAudioFile2 and two NCTAudioPlayer2 controls;
    2) using two NCTAudioFile2 and one NCTAudioTransform2 for mixing and one NCTAudioPlayer2 for playback.

    Note: Some audio cards do not allow to playback several audio files at the same time. Please follow the link: http://www.nctsoft.com/products/NCTAudioStudio2/samples.aspx to get a sample.

  25. How can I convert a file from one format to another and amplify the converted file?

    You can convert file from one format to another using two NCTAudioFile2 controls and amplify it using Amplify method from NCTAudioTransform2.

  26. How can I append sound to an existing file?

    For that you can open existing audio file using NCTAudioFile2 and continue record using NCTAudioRecord2. Please follow the link: http://www.nctsoft.com/products/NCTAudioStudio2/samples.aspx to get a sample.

  27. I can playback audio file with NCTAudioPlayer2, but I can't change volume or volume balance.

    Firstly, check if our standard VB sample works or not. If it works, look for an error in your code.

    Please download program mixapp.exe from our site:
    ftp://ftp.nctsoft.com/download/others/mixapp.zip
    Run it on your computer and send us two screenshots (in some compressed format: png, jpg or gif).
    1. The screenshot of the main window of the program.
    2. The screenshot of the Mixer Driver window. To open it select the Mixer Driver... point form the File menu of the program.

  28. Is there a method for array data access? I'd like to create a simple graphic of audio spectrum.

    For that you can use GetCurrentArray method (NCTAudioPlayer2 and NCTAudioRecord2) or SendBlock method (NCTAudioVisualization2). This method is used for getting currently recording array, particularly for real-time visualization of signal. See NCTAudioVisualization2 VB sample. It shows how to use this method.

  29. How to add NCT's components into my VC++ 6.0 project?

    Please do not use ClassWozard to add our controls into your VC++ application. It works incorrectly with them.

    To insert correctly our controls there have to be 3 strings in your code:

    #import C:\Program Files\NCT\AudioStudio2\Redist\NCTAudioFile2.dll no_namespace
    ...
    IAudioFilePtr FileIn;
    ...
    hr= FileIn.CreateInstance ( __uuidof ( AudioFile ) ) ;

    The similar strings is necessary for all our controls. Please see our MS VC++ 6.0 samples for more information.

  30. I need to have AudioGrabber2 control on two different forms. The problem I run into is the control on the second screen won't read the number of tracks on the CD. It appears that two controls in the same program won't work. If I eliminate one then the other will work. I have to have both controls in order for my program to work properly. Do you have any suggestions or is this a problem with the control?

    Unfortunately it is not possible.

    ASPI interface for Win98/ME and SCSI Pass Through interface for WinNT, Win2000 and WinXP are used by NCTAudioGrabber2 to access to CD drives. It is native SCSI/ATAPI/ATA interface for NT-based systems. All applications (CD Crabbers and CD Burners), which work with CD drives under NT-based systems, use the same interface.

    The SCSI Pass Through interface has the following restrictions:
    1. The only one user at the same time can use this interface.
    2. To transfer data via this interface an application, that use it, has to be run under administrator's rights.

    Here is a restriction from Microsoft's documentation about SCSI Pass Through interface (no.: Q241374): Starting with Windows NT 4.0 Service Pack 4 and beyond (including Windows 2000), there are new access requirements for SCSI (small computer system interface) Pass Through requests. For SCSI pass through requests, both GENERIC_READ and GENERIC_WRITE access must be specified in the dwDesiredAccess parameter of the CreateFile call.

    If both read and write access are not specified, the DeviceIoControl call will fail with ERROR_ACCESS_DENIED (5L).

    Note that only members of the administrator's group have the correct authority to send SCSI pass through requests. Users without administrator authority typically fail either CreateFile or DeviceIoControl with ERROR_ACCESS_DENIED (5L).